Opened 16 years ago

Closed 16 years ago

#72 closed probleme (fixed)

Boîte d'erreur vide lors de l'ajout

Reported by: fabien Owned by: youp3
Priority: critique Milestone: 2.2
Component: e2t Version:
Keywords: Cc:

Description

Je viens d'obtenir une boîte d'erreur vide dans l'E2T en voulant ajouter un fichier. Je n'avais rempli que le commentaire et les champs perso.
PS: Je vous avez fait une petite capture mais on ne pas attachés de fichier ici.

Attachments (1)

Image 1.png (25.7 KB) - added by fabien 16 years ago.
Capture du problème

Download all attachments as: .zip

Change History (10)

Changed 16 years ago by fabien

Capture du problème

comment:1 Changed 16 years ago by fabien

Ah si on peut mettre une fichier-joint :)

comment:2 Changed 16 years ago by youp3

  • Owner changed from somebody to youp3
  • Status changed from new to assigned

Je pense avoir trouvé le problème ligne 82 du fichier class_e2t_post_new_post.php

comment:3 Changed 16 years ago by prolag

Non non c'est normal... ! (pr la ligne 82 (regarde le code d'IPB)) et chez moi je n'ai pas de probleme :s

comment:4 Changed 16 years ago by fabien

Les fichiers de langue sur IBF sont bien à jour ?

comment:5 Changed 16 years ago by anonymous

  • Priority changed from mineur to critique

Je viens de faire le test en mettant les fichiers du trunk et le résultat est identique.

Par contre en ajoutant le nom du fichier, ça fonctionne (pourtant il y a ni lien et ni fichier uploadé. Ce n'est donc pas normal !

comment:6 Changed 16 years ago by prolag

Ca serai pas en rapport avec les modifs que tu a réalisé dans le post machin ? https://e2t.invisionboard.fr/changeset/198

comment:7 Changed 16 years ago by youp3

Pour le message vide oui. Cependant l'ancien message n'était pas adapté je pense : "Vous devez saisir un titre pour le sujet d'au moins deux caractères." (issu de lang_post.php)

C'est dû au fait d'utiliser les fonctions de base d'ipb et non pas nos propres fonctions.

Je pense qu'il faut revoir notre copie.

comment:8 Changed 16 years ago by fabien

Ah oui, j'avais pas fait attention à la révision de Youp3. Il faut passer à $this->objpost_errors? que la "clé de langue" et non pas la chaîne. Un peu plus loin dans le code, il doit y avoir un truc du genre $this->ipsclass->lang[ $this->objpost_errors? ]

comment:9 Changed 16 years ago by youp3

  • Resolution set to fixed
  • Status changed from assigned to closed

Corrigé dans la révision [128]. Je me suis arrangé pour mettre des chaînes propres à E2T

Note: See TracTickets for help on using tickets.